Jump to content
JimD

Super skimmer 125

Recommended Posts

Hi, Im having a problem with my skimmer,,, when I put it on the lowest setting, it overflows. When I move the skimmer to a 5 gallon bucket full of saltwater, it works just fine.... This is a recent development and Ive tried just about everything,,,, Any suggestions ???

Edited by JimD

Share this post


Link to post
Share on other sites

Nope, nothin like that, I havent dosed anything or used any epoxy....

Edited by JimD

Share this post


Link to post
Share on other sites

Nope, nothin like that, I havent dosed anything....

 

Nope, its probably something really simple that Im just overlooking...

Share this post


Link to post
Share on other sites

Nope, nothing...  I wonder if it could be the pump....

Edited by JimD

Share this post


Link to post
Share on other sites

Is it a brand new skimmer? May need break in period


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

This is something that happened all of a sudden, the tank level has not changed... Thank for the help so far....

Share this post


Link to post
Share on other sites

Fixed  it, it was the pump, when I took it apart, the impeller looked a little funky, fortunately, I had a spare, all is back to normal...

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×